@grierson It seems fine, except that you use camelCase naming convention in places, which isn't really a thing in Clojure. Better to use :handler/get-reservations
, or even better, :handler.reservations/get
.
I think I'd also use :dorsia.reservations.repository/memory
and derive it from dorsia.reservations/repository
.
That way you can replace the memory repository with something else in future, should the need arise.
@weavejester Thank you.